BMW 4-Series Forums - Reply to Topic
Thread: 35i audio not working Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the BMW 4-Series Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-26-2014 12:08 AM
CHARB I would suggest that you contact BMW in Germany directly (Google the contact details and speak to someone in authority in customer services or the PA to the CEO of BMW AG) - then you will get some action! Don't fiddle about with BMW in the US!
05-22-2014 05:53 PM
bobterrien
35i audio not working

Bought 435i retract. conv. Apr 8. Apr 18 all audio stopped working. Dealer diagnosed Audio unit Bad. No replacement part in US. It turns out no replacement part in Germany. Looks like another 3 to 4 weeks before part is available. Called and e-mailed BMW USA no help what so ever. Any ideas on how to get action from BMW USA

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome